2

File won't upload and says "Oops - Sorry, Something’s Up!"

If you're having trouble uploading your design file, we can help!
Email your file to designhelp@ponoko.com and we'll advise on how to get it fixed as soon as we can.

You can also read about how to fix this specific error below:

Screen_Shot_2016-05-03_at_4.51.45_PM.png

This error message appears when your file has some tricky little problems that our system is having trouble pinning down. The sorts of issues that cause this error message to appear can be very difficult to spot, and often don't seem to be possible to pick up in Inkscape. So the first thing we suggest doing, if you’re not using it already, is to download the one-month trial version of Adobe Illustrator from their website.

The first thing to do in Illustrator, is to run a ‘clean up’, using the Object > Path > Clean up tool. This will also remove empty text boxes - effectively, where the you might have clicked with the text tool, but entered no text:


RYY9TohRerk-B1O8hgmGtIh7rtue5uzCNXeL1LA5hRDlB_lWh_piK6nQuazIQJADrkZEjBFCB3ThS2v98vRteQQTUwR_K72QOsPWqb_tY0XQWO8WaNc.png

Once you’ve done this, then try re-saving your file and seeing if it will upload.

If this returns a message to say that no cleanup was required, or it does a cleanup but your file will still not upload, you can try using the troubleshooting technique outlined in our 'Self Check with Illustrator' video.

After that if it still won't upload, there are a few more things to try doing. Often the ‘Sorry, something’s up’ error message can be triggered by one or two tiny anchor points in a design that have some information attached to them that our system doesn’t like. To find these anchor points, you need to use the ‘layers’ view.

For example, something in the file pictured below isn’t right, as it won’t upload. I suspect there are one or two rogue anchor points hidden somewhere, but the Object > Path > Clean up tool hasn’t fixed the problem.

lighthouse.png

 

The next thing to do is ‘select all’ and see if there are any clipping masks or compound paths that need releasing: Object > Clipping Mask > Release; and Object > Compound Path > Release. If either of these options are selectable, then it becomes slightly easier to go through the file and locate the issue. Otherwise, you need to start selecting the same ‘stroke color’ or ‘fill color’ and delete each stroke/fill color one at a time, re-saving your file and uploading it to our system until you can isolate exactly what area/color the problem might be hidden in.

Thankfully, this file tells me that there is a compound path that can be released. It is important to pay close attention to the ‘before’ and ‘after’ to see *what* changes in the file. In this case, I noticed that the letters in the little word ‘house’ have changed slightly once the compound paths have been released - the letters are now all filled in with raster engraving.

Using the ‘layers’ view, I then scanned through each and every anchor point, to find the text components of the word ‘house’. I spotted that there was a plain white box next to one of the text components, that didn’t seem to have any information attached to it:


rogue_anchor_point.png


I then zoomed in really close on the design, and spotted the culprit: a rogue anchor point sitting overtop the letter ‘u’:

Anchor_found.png

Once I deleted this anchor point, the file was able to upload just fine.

Sometimes, the information in the ‘layers view’ might reveal little white boxes such as the one pictured above, which indicate there is ‘something extra’ in the file. Sometimes they might be grayed out as well, if they have an ‘appearance’ applied to them (gray ones can be easier to spot too!)

Of course, if you have multiple designs in your file, it is easier to delete all but *one* to begin with. Once you have figured out where the rogue anchor points are, it is far easier to duplicate a correct design, than it is to find all of the rogue anchor points and have to delete them.

If you’ve checked all of these issues and your file is still not uploading, then drop us a line at service-at-ponoko-dot-com and we’ll be happy to take a look at your file for you.





3 comments

Please sign in to leave a comment.