Forums/Tutorials/Design File Troubleshooting

File won't upload and says "Please check your line colors"

Catherine Field-Dodgson
posted this on May 09, 2012 16:12

If you're having trouble uploading your design file, we can help!

Email your file to designhelp@ponoko.com and we'll advise on how to get it fixed as soon as we can. 

This error message can appear for the following reasons:

Your designs have the wrong blue or red values 

Your design has lines/strokes that are black 

Your design is in CMYK mode

Your designs have the wrong blue or red values - how to find lines with the wrong color:

Your lines must be either:

vector_lines.png

The following steps will help you find lines that do not have correct formatting.

Illustrator

  1. Click on a line with the correct color values.
  2. From the Select menu choose Same > Fill & Stroke. This will select all the lines that have the same, correct value.
  3. From the Object menu choose Hide > Selection to hide these correct lines from display on your artboard.
  4. Repeat this process until there are no lines left and/or you have found the lines that had the wrong color values.
  5. With an apparently blank artboard choose Select > All from the Select menu to see if there are any invisible objects still in your design that might be causing errors. If anything is selected you can delete it.

You can watch a video on Self Checking design files here.

CorelDRAW

  1. Click on a line with the correct color values.
  2. From the Edit menu choose Find and Replace > Find Objects > Find objects that match the currently selected object
  3. In the next window, choose "Edit" and uncheck the "Object Types" box (you can specify a lot of properties if you want: fill, outline, outline width, overprints, and more)
  4. Next choose "Select All". If any object is part of group, CorelDRAW will ask you if you want to ungroup
  5.   

Inkscape

Unfortunately Inkscape doesn't have a function that allows you to select lines of the same color. There are rumors of this functionality in version 0.49 so keep an eye out for that release.

Your design has lines/strokes that are black - How to convert them to fills:

If you have a thicker black, gray or white stroke/line in your design, then you’ll need to expand these to *fills*. We recommend all Raster engraving lines to be at least 1mm before you expand them to ensure the engraving comes out. 


1mm_stroke.png

 

Illustrator:

To turn a black/gray/white stroke into a filled shape in Illustrator, select your line and make sure it is at least 1mm.

Use the Object > Path > Outline Stroke command to turn your lines into filled shapes.


outline_stroke.png

The black stroke colors will then turn into black fills:


filled_paths.png

 

Inkscape:

To turn a black/gray/white stroke into a filled shape in Inkscape, select your line and use the Path > Stroke to path command:

Expand_Inkscape.png

The black strokes will then turn into black fills:


Expanded_Inkscape.png

If you’ve followed all these steps and your file is still not uploading, then drop us a line at service-at-ponoko-dot-com and we’ll happily take a look at your file for you.

Your design is in CMYK mode - How to check the color mode:

Adobe Illustrator

Firstly, check the color mode of your document. (It's best to start working in our templates as the color mode will be set right)

From the File menu, select Document Color Mode > RGB Color

Screen_Shot_2013-10-15_at_1.13.47_PM.png

 

When saving your file as an ‘Illustrator EPS’, check that your screen matches the panel below (with all of the boxes under ‘Options’ remaining unticked). The most important one which is causing you trouble now is "Include CMYK Postscript in RGB Files".

Once you've resaved in this fashion, your file should upload correctly.

Screen_Shot_2013-10-02_at_1.32.05_PM.png

CorelDRAW

Go to Tools > Color Management > Default Settings. Make sure your default color settings are set the same as this image.

corel-RGBcolor_mode.gif

If you are using any version of CorelDRAW previous to X6, you MUST export your file as a SVG. You can read more about that in our CorelDRAW starter kit.

If you are using CorelDRAW X6, you can read about how to export your file here: How to Export CorelDRAW X6 files for use with Ponoko

Inkscape

You must export your Inkscape file as an Inkscape SVG. You can read more about exporting Inkscape files in our Inkscape Starter kit

 

 

 

Comments

User photo
Keith

Note: if the opacity slider in Inkscape is not at 100% (which can happen without your noticing it during editing of multiple objects) you will get this message even if your colors are okay.  So check that opacity box (probably the blur bar too, although I don't know.

July 02, 2013 15:24